Page load takes 15 seconds (Wild West Domains)

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Threaded View

Hi folks,

With my website, I am seeing a delay before the page appears
in Firefox. My hosting service is Wild West Domains.

6 months ago I optimized the PHP code and it was loading
in 1-2 seconds every time. Day after day performance was
great and I was happy.

Then about 2 months ago, all of a sudden I noticed
delays of 10-15 seconds. I'd get a blank page for
literally that long and then my page will appear.

The hosting service, which is a sister company of
Wild West Domains called, has
given me the runaround, saying it is my page's use
of images that is the source of the problem, and
even saying I should buy a more expensive plan
to fix the problem.

(I'm using images from other web pages, however in Firefox
this shouldn't be a problem.... It always displays the page
before the images are loaded....)

So I removed all off-site images. The only
external thing on the page is some Google Adsense
ads. There is still a delay of up to 15 seconds.

Has anyone seen this kind of problem with WWD
or a related company?

Is there a way to tell Firefox and IE to display the page
before all of the various images are loaded?


Re: Page load takes 15 seconds (Wild West Domains)

Flark schrieb am 06.09.2008 15:39:

Quoted text here. Click to load it

First Check with firebug or the "resource" view in the developer console
of safari what element is blocking your rendering.

Mit freundlichen Grüßen
Holger Jeromin

Re: Page load takes 15 seconds (Wild West Domains)

On 09/06/08 06:39 am, Flark wrote:
Quoted text here. Click to load it
  Hmm. No URL. No way to observe the behavior.

jmm (hyphen) list (at) sohnen-moe (dot) com
(Remove .AXSPAMGN for email)

Site Timeline