auth_digest produces strange error

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Threaded View

Invalid command 'AuthDigestProvider', perhaps mis-spelled or defined by
a module not included in the server configuration

this is what I get when I try to reload/restart apache after adding the
lines from the apache-site to my vhost running on an ubuntu6 with an
apache2.0.55. The auth_digest.load is symlinked from mods-available to
mods-enabled. All lines have been copyandpasted from the apachesite and
just the parameters have been adjusted.
I am a quite irritated as all other lines produce no error.
Can someone help me out on how to fox this problem? The apache site
mentions mod_authn_file that is needed to use this directive but it is
not within my mods-available directory and I am having trouble believing
that other mods that depend on this one have been placed there by
default without this one. So I guess the error is on my part and the
mod_authn_file is not needed.

greets, B.S.

my vhost includes these lines:
         <Directory ---mypath--->
                 Options Indexes SymLinksIfOwnerMatch
                 AllowOverride None
                 Order deny,allow
                 allow from all

                 AuthType Digest
                 AuthName "testing authentification"
                 AuthDigestProvider file
                 AuthUserFile /etc/apache2/htpasswds
                 AuthDigestDomain ---mydomain---
                 Require valid-user

Re: auth_digest produces strange error

B.Schulz wrote:
Quoted text here. Click to load it

Try alt.apache.configuration maybe?

Remove the "x" from my email address
Jerry Stuckle
JDS Computer Training Corp.

Site Timeline