X11 and XEmacs

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Threaded View
I run Windows XP at home and my university network uses Linux. I've
been wanting a way to connect to the university network from home, and
so a while back I installed Putty. The problem was that using xemacs
was a hassle because it just opens in the terminal and is therefore
cumbersome to use. When I found out about X11, I installed cygwin-x and
XEmacs on my Windows XP computer at home, in the hopes that opening
Xemacs in Putty would now result in the file being opened in my Windows
XEmacs installation. I left the default tunnels setting at localhost:0
because I wasn't sure what this should be. But now when I connect with
the university network through putty and type "xemacs," there is no
response at all. It doesn't open in the terminal nor in Windows.

Can anyone give a suggestion on how to configure my Windows XEmacs with

Re: X11 and XEmacs

gabriel.murray@gmail.com writes:
Quoted text here. Click to load it


unnecessary, really

A few things that might discourage you from what you think you want
today: Emacs is best enjoyed knowing the keyboard shortcuts.  Once
that's the case, you have no need for the bloat of the gui.  Just run
xemacs -nw and do your thing in text mode once you set putty to behave
with the meta key.

Second comment: X is a pig, and if your connection gets disrupted
you're kinda screwed.  If you can use vnc-server instead on that
school computer and a VNC viewer (many implementations of VNC out
there to choose from) you'll be better off since VNC is reconnectable
and a lot lighterweight than the chatty X protocol.

Nontheless...to address your problem, here are some things to check.

First, connect with putty (or cygwin ssh) and turn on debugging and
verify that the X forwarding is both turned on on your client and
supported by the ssh server on the school computer.  If it's not
turned on in the sshd config file on the university machine, you won't
be playing with X I'm afraid.

Second, echo $DISPLAY on the university computer and make sure it's
pointing somewhere into the tunnel.  localhost:20 or some such.  If
it's :0, that's the physical terminal, and not what you want.  If it's
not getting set to something like :10 or higher odds are either X
forwarding is not available via the sshd_config file on the university
server, you haven't enabled it in putty, or you have a local unix
config file .bashrc, .profile, /etc/profile, or something that is
overwriting DISPLAY after ssh sets it.

Third, make sure Cygwin-X is actually invoked and running on your
machine.  Instead of the relatively large xemacs, xclock makes a nice
nimble test program to run from the university machine.

Good luck!

Best regards,
Todd H.
http://www.toddh.net /

Re: X11 and XEmacs

Thanks for the tips, Todd. You're probably right that I should just get
more proficient at using emacs keyboard shortcuts and not the GUI.

Re: X11 and XEmacs

gabriel.murray@gmail.com writes:
 > Can anyone give a suggestion on how to configure my Windows XEmacs
 > with Putty?

Todd has good advice.

You might also look at an alternative approach which is to use TRAMP.
That allows you to run emacs on your local machine while it fetches
and stores copies of the remote files you are working on.  There are a
number of underlying methods available such as ssh, scp and plink.
See the Info in XEmacs.
Pete Forman                -./\.-  Disclaimer: This post is originated
WesternGeco                  -./\.-   by myself and does not represent
pete.forman@westerngeco.com    -./\.-   opinion of Schlumberger, Baker
http://petef.port5.com -./\.-   Hughes or their divisions.

Site Timeline