X window on ssh

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Threaded View

I am trying to run cygwin with ssh into Linux machine. I use startx to
start Xwindow manager on WinXP. Then i do :

ssh -X -l <user> <IP-of-Linux>

On Linux terminal :

export DISPLAY=:0.0
xterm &

At this point i get
Xlib: connection to :0.0 refused by server.
Xlib: No protocol specified.

How do i pass the X application back to my Cygwin-X11 Xserver.
What am i missing.


Re: X window on ssh

Quoted text here. Click to load it

Don't do that, sshd will set $DISPLAY to an appropriate value.  If
$DISPLAY is not set, check that X forwarding is enabled on the server.
(For OpenSSH, check X11Forwarding and XAuthLocation, details will vary
for other SSH servers.)

If you need to mess with SSH's $DISPLAY then you're doing something

(Actually, that isn't always true, but if you know that then you know
enough to figure out what you need to do and when.)

Darren Tucker (dtucker at zip.com.au)
GPG key 8FF4FA69 / D9A3 86E9 7EEE AF4B B2D4  37C9 C982 80C7 8FF4 FA69
    Good judgement comes with experience. Unfortunately, the experience
usually comes from bad judgement.

Re: X window on ssh

a2zasics wrote:
Quoted text here. Click to load it

I've been using cygwin to solaris quite a lot recently. I didn't have to
mess around with display settings. Just one line in cygwin:
ssh -X -u root
did the trick.
Did you know this works too?:
ssh -X root@

The IP address has been changed to protect the guilty.

Site Timeline