VNC, OpenSSH tunnelling on Windows XP Issue

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Threaded View

I installed, OpenSSH on 2 PC's located on the same lan segment

Both PC's run windows XP Pro SP2.  I created a local group and
assigned several accounts to the passwd file.  Both are able to
connect to each other using Putty ssh client.  (I have also used the
ssh.exe supplied with the OpenSSH).    I do not have full Cygwin
installed on either machine, only the OpenSSH.

I then downloaded TightVNC and installed full installs (Sever and
Viewers) on both machines.  The WinVNC service was registered and
installed. and settings to enable and always use loopback where set
along with connection passwords where set.

I created a putty settings profile on each machine to allow access to
the other machine, consisting of the target machines IP address and
port 22, then I configured tunnelling with a source set to 5900 and
destination as localhost:5901 and tried connecting.   Initially I was
able to connect to either server from the other and then open the
TightVNC viewer and connect to the other PC using localhost:1.

All was going well....then at a point in time this stopped working on
both PC's when trying to connect to the other.

At this point I was able to connect still to localhost:0 (the local
machine) giving the ugly looping local screen refresh....

I have disabled all firewalls and the issue remains, howevr if I try
to VNC without going through the SSH tunnel it connects without issue.
  I have tried de-installing and re-installing the openSSH and
TightVNC but the problem has remained.....I also tried accessing using
the OpenSSH ssh utility by entering

     ssh -v -L 9001: stueyc@

I also tried localhost in place of without any success.

When using verbose mode I received the following message when trying
to connect to the target machine using the VNC viewer.

   channel 2: open failed: connect failed: Connection refused

Any help or shared experiences on this much appreciated as this is a
new area I have been looking at over the last days.

thanks in advance
Stuart Coney

Re: VNC, OpenSSH tunnelling on Windows XP Issue


here is the ssh verbose output log from ssh, hopefully this may help
somebody to advise what could be wrong here....thanks


C:\Program Files\OpenSSH\bin>ssh -v -L 5901:localhost:5900
OpenSSH_3.8.1p1, OpenSSL 0.9.7d 17 Mar 2004
debug1: Reading configuration data /etc/ssh_config
debug1: Connecting to [] port 22.
debug1: Connection established.
debug1: identity file /home/StueyC/.ssh/identity type -1
debug1: identity file /home/StueyC/.ssh/id_rsa type -1
debug1: identity file /home/StueyC/.ssh/id_dsa type -1
debug1: Remote protocol version 2.0, remote software version
debug1: match: OpenSSH_3.8.1p1 pat OpenSSH*
debug1: Enabling compatibility mode for protocol 2.0
debug1: Local version string SSH-2.0-OpenSSH_3.8.1p1
debug1: SSH2_MSG_KEXINIT sent
debug1: SSH2_MSG_KEXINIT received
debug1: kex: server->client aes128-cbc hmac-md5 none
debug1: kex: client->server aes128-cbc hmac-md5 none
debug1: SSH2_MSG_KEX_DH_GEX_REQUEST(1024<1024<8192) sent
debug1: expecting SSH2_MSG_KEX_DH_GEX_GROUP
debug1: SSH2_MSG_KEX_DH_GEX_INIT sent
debug1: expecting SSH2_MSG_KEX_DH_GEX_REPLY
debug1: Host '' is known and matches the RSA host key.
debug1: Found key in /home/StueyC/.ssh/known_hosts:1
debug1: ssh_rsa_verify: signature correct
debug1: SSH2_MSG_NEWKEYS sent
debug1: expecting SSH2_MSG_NEWKEYS
debug1: SSH2_MSG_NEWKEYS received
debug1: SSH2_MSG_SERVICE_ACCEPT received

                            ****USAGE WARNING****

This is a private computer system. This computer system, including all
related equipment, networks, and network devices (specifically
Internet access) are provided only for authorized use. This computer
may be monitored for all lawful purposes, including to ensure that its
is authorized, for management of the system, to facilitate protection
unauthorized access, and to verify security procedures, survivability,
operational security. Monitoring includes active attacks by authorized
to test or verify the security of this system. During monitoring,
may be examined, recorded, copied and used for authorized purposes.
information, including personal information, placed or sent over this
may be monitored.

Use of this computer system, authorized or unauthorized, constitutes
to monitoring of this system. Unauthorized use may subject you to
prosecution. Evidence of unauthorized use collected during monitoring
may be
used for administrative, criminal, or other adverse action. Use of
this system
constitutes consent to monitoring for these purposes.

debug1: Authentications that can continue:
debug1: Next authentication method: publickey
debug1: Trying private key: /home/StueyC/.ssh/identity
debug1: Trying private key: /home/StueyC/.ssh/id_rsa
debug1: Trying private key: /home/StueyC/.ssh/id_dsa
debug1: Next authentication method: keyboard-interactive
debug1: Authentications that can continue:
debug1: Next authentication method: password
StueyC@'s password:
debug1: Authentication succeeded (password).
debug1: Connections to local port 5901 forwarded to remote address
debug1: Local forwarding listening on port 5901.
debug1: channel 0: new [port listener]
debug1: channel 1: new [client-session]
debug1: Entering interactive session.
Last login: Wed Oct  6 14:44:41 2004 from stueyc-dell
Microsoft Windows XP [Version 5.1.2600]
(C) Copyright 1985-2001 Microsoft Corp.

d:\users\stueyc>debug1: Connection to port 5901 forwarding to
localhost port 590
0 requested.
debug1: channel 2: new [direct-tcpip]
channel 2: open failed: connect failed: Connection refused
debug1: channel 2: free: direct-tcpip: listening port 5901 for
localhost port 59
00, connect from port 1124, nchannels 3

Re: VNC, OpenSSH tunnelling on Windows XP Issue

Quoted text here. Click to load it

Site Timeline