Using stunnel for https proxying

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Threaded View
I'm trying to use stunnel to add https(SSL) support to gaim.

Here's what I'm doing:

I setup stunnel on my local machine like this:

accept = 8080
connect = ip.of.proxy.server:80

Gaim is setup to connect to I set the HTTP
proxy in gaim to localhost:8080.

Is this actually possible to do with this setup? I've read that stunnel
can't handle 'http connect' requests. So it seems that this setup would
not be possible... although some verification would be good.

There is also a patch that adds https proxying to stunnel. In the
config file, you specify both the proxy to connect to, and to what
server you want the proxy to connect. I set this up, disabled the proxy
option in gaim, and instead of connecting directly to login.oscar... I
set it to connect to localhost:8080. This however, yields this error:

2004.12.09 08:56:05 LOG4[14019:1026]: return code not 200: HTTP/1.1 502
Proxy Error ( The specified Secure Sockets Layer (SSL) port is not
allowed. ISA Server is not configured to allow SSL requests from this
port. Most Web browsers use port 443 for SSL requests.  )

It seems to indicate that the proxy server wants me to connect from
port 443 on my local machine? How can I do that when unprivelaged users
can't bind to ports below 1024?

Any help here!?
I know this may sound confusing, so apologies in advance.


Re: Using stunnel for https proxying

Ok... I figured out that it's not referring to the port I'm connecting
from, but rather the port to connect to the aim server. So, if I change
the port to connect to on from 5190 to the ssl port
443, then I get further. However, this time, I get a SSL3_GET_RECORD
wrong version/handshake failure type thing.
Anyone know what this is indicitive of and how to fix it?


Site Timeline