(Unix) Login with ssh ... TERM not set.

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Threaded View
The account on the target machine I ssh into has sh as a default shell. Since
I prefer bash, but don't want to manually invoke 'bash' every time I log in,
I tried the following comand:

  ssh HOST -l USERID /usr/local/bin/bash --rcfile MYBASHRC -i

This does nearly what I want, but I get the error messages

  bash: no job control in this shell
  stty: : Not a typewriter

The stty message is caused by the execution of MYBASHRC, which contains the

  stty erase ^H

It seems that both messages have the same cause, i.e. that bash does not
believe that it is invoked by a terminal. Indeed, the TERM variable is set
to "dumb".

When I login the "conservative" way, i.e.

  ssh HOST -l USERID

and then invoke bash manually, everything works in the normal way and the
TERM variable is set to TERM. I guess that since ssh just thinks it should
remotely execute some command, it does not know that I am going to use
an interactive shell, and therefore does not care to set TERM for me.

Is there a way to tell ssh to execute my remote command "like a shell"?
I checked the man-pages, but did not find a suitable command line switch.


Re: (Unix) Login with ssh ... TERM not set.

Quoted text here. Click to load it
Quoted text here. Click to load it

You want to force the ssh server to allocate a pseudo terminal (this is
"-t" with OpenSSH's ssh, other SSH implementations may vary).

Darren Tucker (dtucker at zip.com.au)
GPG key 8FF4FA69 / D9A3 86E9 7EEE AF4B B2D4  37C9 C982 80C7 8FF4 FA69
    Good judgement comes with experience. Unfortunately, the experience
usually comes from bad judgement.

File Permissions

I have bash set as the default terminal on the SSH server running
Slackware. Unfortunately, when I log onto the system through an SSH
client, the default permissions on all folders and files that I create
through the SSH client (WinSCPx) is rwxr-xr-x. What I have set for a
default, which works when I log on locally to the system, is rwxrwx---.

Could anyone tell me how I can configure SSH to create files and folders
with a specific set of permissions? Does SSH pick up the default
terminal of the operating system or is there a settings in the
sshd_config file that needs to be modified?

Any assistance is greatly appreciated.

S. Lee

Site Timeline