tunnel device open failure openssh linux

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Threaded View
I tried to build a ssh vpn between to linux boxes with openssh.

Remote box is and local box is, so on the local box my
ssh_config looks like that:

| Host *
|   Tunnel yes

and on the remote box my sshd_config is:

| Protocol 2
| PermitRootLogin without-password
| X11Forwarding yes
| PermitTunnel yes
| Subsystem    sftp    /usr/libexec/sftp-server

from the local box I run as root

# ssh -vw 0:0
OpenSSH_5.0p1, OpenSSL 0.9.8g 19 Oct 2007
debug1: Reading configuration data /etc/ssh/ssh_config
debug1: Applying options for *
debug1: Connecting to [] port 22.
debug1: Connection established.
debug1: permanently_set_uid: 0/0
debug1: identity file /root/.ssh/identity type -1
debug1: identity file /root/.ssh/id_rsa type 1
debug1: identity file /root/.ssh/id_dsa type -1
debug1: Remote protocol version 2.0, remote software version OpenSSH_5.1
debug1: match: OpenSSH_5.1 pat OpenSSH*
debug1: Enabling compatibility mode for protocol 2.0
debug1: Local version string SSH-2.0-OpenSSH_5.0
debug1: SSH2_MSG_KEXINIT sent
debug1: SSH2_MSG_KEXINIT received
debug1: kex: server->client aes128-cbc hmac-md5 none
debug1: kex: client->server aes128-cbc hmac-md5 none
debug1: SSH2_MSG_KEX_DH_GEX_REQUEST(1024<1024<8192) sent
debug1: expecting SSH2_MSG_KEX_DH_GEX_GROUP
debug1: SSH2_MSG_KEX_DH_GEX_INIT sent
debug1: expecting SSH2_MSG_KEX_DH_GEX_REPLY
debug1: Host '' is known and matches the RSA host key.
debug1: Found key in /root/.ssh/known_hosts:2
debug1: ssh_rsa_verify: signature correct
debug1: SSH2_MSG_NEWKEYS sent
debug1: expecting SSH2_MSG_NEWKEYS
debug1: SSH2_MSG_NEWKEYS received
debug1: SSH2_MSG_SERVICE_ACCEPT received
debug1: Authentications that can continue: publickey,password, \
debug1: Next authentication method: publickey
debug1: Trying private key: /root/.ssh/identity
debug1: Offering public key: /root/.ssh/id_rsa
debug1: Server accepts key: pkalg ssh-rsa blen 533
debug1: read PEM private key done: type RSA
debug1: Authentication succeeded (publickey).
debug1: Requesting tun unit 0 in mode 1
debug1: sys_tun_open: failed to open tunnel control interface: No \
        such file or directory
Tunnel device open failed.
Could not request tunnel forwarding.
debug1: channel 0: new [client-session]
debug1: Entering interactive session.

my question is how come that he cannot open the tunnel control
interface, did I miss something?

Thank you in advance.

Regards, y0shi

Re: tunnel device open failure openssh linux

The error msg is not that descriptive but i found out that i need to
modprobe tun because the tunnel kernel driver was modular on my linux.

Regards, y0shi

Quoted text here. Click to load it

Site Timeline