Telnet to Windows; Start Plink to another system fails

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Hi All,

I have a script that telnets to a windows box, then starts plink to
open a com port on that server.

The issue is that the connection will only work if I type
Sloooooowly ... the script fails miserably with lots of garbage
characters being sent to the com port.

I tried telnet to the Windows box then using plink to telnet with the
same result.

Also, when it does work ... typing slow ... every key typed is echoed
back ...


# llss

instead of

# ls

Any help is greatly appreciated!


============== log =======================================
Welcome to Microsoft Telnet Service

login: motocapsqa


Welcome to Microsoft Telnet Server.
\plink.exe -load COM6_115200_8N1

# ls --color=never
ls -color=?ever
ls: invalid option -- o
BusyBox v1.9.1 (2008-06-27 06:45:31 EDT) multi-call binary

Usage: ls [-1AacCdeFilnpLRrSsTtuvwxXhk] [filenames...]

List directory contents

# route add -net netmask gw
ro?ue? ad -net 10.13.22?.0?n?em?ak 2?5.255?.25.0 gw 192.16?.0.?20
-sh: ro?ue?: not found

Site Timeline