SunOS 5.9 to AIX 5.3 ssh getting Connection closed

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Threaded View
I've tried a number of things but can't figure out what's going on.
This worked as of May 31 and then started getting this error--no known
changes from that date.  Soliciting ideas...

sunbox# ssh -v TARGETBOX
Sun_SSH_1.1, SSH protocols 1.5/2.0, OpenSSL 0x0090700f
debug1: Reading configuration data /etc/ssh/ssh_config
debug1: Rhosts Authentication disabled, originating port will not be
debug1: ssh_connect: needpriv 0
debug1: Connecting to TARGETBOX [] port 22.
debug1: Connection established.
debug1: identity file /home/testid/.ssh/identity type -1
debug1: identity file /home/testid/.ssh/id_rsa type 1
debug1: identity file /home/testid/.ssh/id_dsa type 2
debug1: Remote protocol version 2.0, remote software version
debug1: match: OpenSSH_3.8p1 pat
debug1: Enabling compatibility mode for protocol 2.0
debug1: Local version string SSH-2.0-Sun_SSH_1.1
debug1: Failed to acquire GSS-API credentials for any mechanisms (No
credentials were supplied, or the credentials were unavailable or
mech_dh: Invalid or unknown error
debug1: SSH2_MSG_KEXINIT sent
debug1: SSH2_MSG_KEXINIT received
debug1: kex: server->client aes128-ctr hmac-md5 none
debug1: kex: client->server aes128-ctr hmac-md5 none
debug1: Peer sent proposed langtags, ctos:
debug1: Peer sent proposed langtags, stoc:
debug1: We proposed langtags, ctos: en-US
debug1: We proposed langtags, stoc: en-US
debug1: expecting SSH2_MSG_KEX_DH_GEX_GROUP
debug1: dh_gen_key: priv key bits set: 138/256
debug1: bits set: 530/1024
debug1: SSH2_MSG_KEX_DH_GEX_INIT sent
debug1: expecting SSH2_MSG_KEX_DH_GEX_REPLY
debug1: Host 'TARGETBOX' is known and matches the RSA host key.
debug1: Found key in /home/testid/.ssh/known_hosts:2452
debug1: bits set: 492/1024
debug1: ssh_rsa_verify: signature correct
debug1: newkeys: mode 1
debug1: SSH2_MSG_NEWKEYS sent
debug1: expecting SSH2_MSG_NEWKEYS
debug1: newkeys: mode 0
debug1: SSH2_MSG_NEWKEYS received
debug1: done: ssh_kex2.
debug1: Authentications that can continue: publickey,password,keyboard-
debug1: Next authentication method: publickey
debug1: Trying private key: /home/testid/.ssh/identity
debug1: Trying public key: /home/testid/.ssh/id_rsa
debug1: Server accepts key: pkalg ssh-rsa blen 149 lastkey 1140b0 hint
debug1: read PEM private key done: type RSA
debug1: Authentication succeeded (publickey)
debug1: channel 0: new [client-session]
debug1: send channel open 0
debug1: Entering interactive session.
debug1: ssh_session2_setup: id 0
debug1: channel request 0: env
debug1: channel request 0: env
debug1: channel request 0: env
debug1: channel request 0: env
debug1: channel request 0: env
debug1: channel request 0: pty-req
debug1: channel request 0: shell
debug1: fd 4 setting TCP_NODELAY
debug1: channel 0: open confirm rwindow 0 rmax 32768

debug1: channel 0: rcvd eof
debug1: channel 0: output open -> drain
debug1: channel 0: obuf empty
debug1: channel 0: close_write
debug1: channel 0: output drain -> closed
debug1: client_input_channel_req: channel 0 rtype exit-status reply 0
debug1: channel 0: rcvd close
debug1: channel 0: close_read
debug1: channel 0: input open -> closed
debug1: channel 0: almost dead
debug1: channel 0: gc: notify user
debug1: channel 0: gc: user detached
debug1: channel 0: send close
debug1: channel 0: is dead
debug1: channel 0: garbage collecting
debug1: channel_free: channel 0: client-session, nchannels 1
Connection to TARGETBOX closed.
debug1: Transferred: stdin 0, stdout 0, stderr 56 bytes in 0.3 seconds
debug1: Bytes per second: stdin 0.0, stdout 0.0, stderr 167.0
debug1: Exit status 255

Some additional detail:

 1.  testid (not it's real name) is supposed to be trusted from the
Sun box to the AIX box so no password is entered
 2.  Tried removing testid's .profile, no change
 3.  Tried wide-open permissions and then restricted permissions on
testid's home directory, no change
 4.  Tried removing/renaming testid's .ssh directory, no change
 5.  Works OK when doing ssh localhost as testid on the AIX box
 6.  Works OK as my own user ID (requiring password)

I'm not fully conversant with SSH so I'm not sure what to make of the
debug messages which seem to indicate that "Authentication succeeded"
and it enters an "interactive session" but then inexplicably closes
"channel 0" only a few moments later.  Would appreciate any assistance.

Re: SunOS 5.9 to AIX 5.3 ssh getting Connection closed

Quoted text here. Click to load it
[snip client log]

The really interesting output would be from the server at the other
end.  See the FAQ on for an example of how to do that.

Looking at your output, it appears that the server is aborting for
some reason around the time the client requests a pty.  You could
check that the pty master/slave devices are still in /dev/ with
correct permissions.  Does "ssh yourserver echo foo" work?

Darren Tucker (dtucker at
GPG key 8FF4FA69 / D9A3 86E9 7EEE AF4B B2D4  37C9 C982 80C7 8FF4 FA69
    Good judgement comes with experience. Unfortunately, the experience
usually comes from bad judgement.

Re: SunOS 5.9 to AIX 5.3 ssh getting Connection closed

Quoted text here. Click to load it

I've seen something like this on HP-UX, round about OpenSSH v3.7,
when both UsePAM and privsep were on.

Elvis Notargiacomo  master AT barefaced DOT cheek /

Site Timeline