ssh pub-key login failes randomly

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Threaded View
I have a very strange problem: Since a few days SSH public-key logins from
one machine to another fail randomly. About every 10th time ssh either
prompts for a password or simply fails with message:

ssh_rsa_verify: RSA_verify failed: error:04077068:rsa
routines:RSA_verify:bad signature
key_verify failed for server_host_key

Before, everything always worked great and I didn't update OpenSSH / OpenSSL

The two hosts run Debian and use the same versions of OpenSSH / OpenSSL from
the current stable:

SSH: 3.4p1-1.woody.3
OpenSSL: 0.9.6c-2.woody.6

I tried different SSH 2 DSA & RSA keys.

I've put the outputs of "ssh -vvv" online at:

ssh_ok.txt: Login worked. No problem.
ssh_failed.txt: Login fails with "ssh_rsa_verify: RSA_verify failed"
ssh_pass.txt: Login fails and prompts for password.

I have not experienced any problems connecting to either of the two hosts
from any other host.

Does anybody have an idea what the reason for this could be?


Re: ssh pub-key login failes randomly

Bad memory?

  Richard Silverman

Re: ssh pub-key login failes randomly

Quoted text here. Click to load it

That's what I thought first, but memory seems to be OK.

After downgrading the Linux kernel from 2.4.25 to 2.4.18 on the client
machine the problem seems to have vanished.

Very strange. Thanks for you help.


Site Timeline