SSH Port Forwarding Question

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Threaded View
I am having a problem using OpenSSH_3.8.1p1 Debian 1:3.8.1p1-4,
OpenSSL 0.9.7d on the client and OpenSSH_3.7p1 for Solaris 7 on the

I have port forwarded the default Oracle port from my local machine
through a bastion host to my Oracle machine like so:

ssh -L 1521:oracle_box:1521 username@bastion

And all works fine at first.  I am doing some load testing on an
application and am trying to see how many instances I can run at one
time.  Each instance of the application initiates its own connection
to the Oracle database through the SSH tunnel.  This works great until
I get to 25 hosts and then I start seeing this error on the console of
the bastion host where I have ssh'd to:

channel 53: open failed: administratively prohibited: open failed

It appears there is some sort of hard limit that I have reached and I
am wondering if this is something I can change on the client side, the
server side, or whether it is hardcoded into either the server or
client and I'm out of luck.  I do not have the luxury of simply
selecting another local port to forward because of the way the
application is configured so I'd really like to be able to get at
least 100 connections through per tunnel.  I have tried this on 3
different Linux boxes, all with the same result.

Re: SSH Port Forwarding Question

The per-process limit on concurrent open file descriptors for sshd on the
server is probably set to 64; try increasing it.

  Richard Silverman

Site Timeline