ssh port forwarding problem

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Threaded View

I want to forward a local port from mysystem to a webserver on port
I use OpenSSH (OpenSSH_3.0.2p1, SSH protocols 1.5/2.0, OpenSSL
0x0090601f) on all my systems.
The command I use is:
ssh -L 9110:webserver:80 mysystem

The problem is that an interactive session with mysystem is started.
I added some debug, and this is what it shows:
debug1: Sent encrypted session key.
debug1: Installing crc compensation attack detector.
debug1: Received encrypted confirmation.
debug1: Trying RSA authentication via agent with 'me'
debug1: Remote: Adding to environment: SSH_USER=me
debug1: Received RSA challenge from server.
debug1: Sending response to RSA challenge.
debug1: Remote: RSA authentication accepted.
debug1: RSA authentication accepted by server.
debug1: Requesting pty.
debug1: Connections to local port 9110 forwarded to remote address
debug1: Local forwarding listening on port 9110.
debug1: fd 6 setting O_NONBLOCK
debug2: fd 6 is O_NONBLOCK
debug1: channel 0: new [port listener]
debug1: Requesting shell.
debug1: Entering interactive session.

As you can see, the forwarding starts but an interactive session is

I am doing something wrong here?

Any help much appreciated.


Re: ssh port forwarding problem


AFAIK, this is correct.
If you don't want an interactive shell use -N option.

dompie wrote:

Quoted text here. Click to load it

Site Timeline