ssh hangs on HPUX 10.20 when sending commands

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Threaded View
     I'm using HPUX 10.20 and OpenSSH 3.6.1p1.  If I try something as
simple as

ssh user@host ls

ssh hangs before I get any output no matter how often I try.  If I run
ssh in debug mode, the first time I do so in a new terminal, ssh also
hangs here:

debug1: channel 0: new [client-session]
debug3: ssh_session2_open: channel_new: 0
debug2: channel 0: send open
debug1: Entering interactive session.
debug2: callback start
debug2: ssh_session2_setup: id 0
debug1: Sending command: ls
debug1: channel 0: request exec
debug2: callback done
debug1: channel 0: open confirm rwindow 0 rmax 32768

Every subsequent attempt at using ssh with debug output in that
terminal succeeds.  However, if I try a new terminal, ssh with debug
output freezes that first time, and works subsequently.  I want to be
able to use ssh in a script and feel silly having to prime ssh.  Does
anyone know if its possible to overcome this problem?


Jason Mazzotta

Re: ssh hangs on HPUX 10.20 when sending commands writes:
Quoted text here. Click to load it

I haven't encountered this before, but one thing that comes to mind is
to check .profile, and .kshrc or shell init scripts for command that
perhaps falsely assume an interactive login and cause this
non-interactive login to be squirrely.

Todd H. /

Re: ssh hangs on HPUX 10.20 when sending commands

Hi Todd,
        I think the problem is with the HPUX client.  I can manage to
get the ssh session to hang just by changing the size of the terminal
window.  If the terminal window is small, the debug mode works alright.
 If the terminal is full-screen, even debug mode doesn't work.  I did
check the rc files I can find and they don't do much but set alias's
and environmental variables. I should think that if a config file was
causing things to hang, it would do so whenever I tried to simply log
in, a process which does work.

Jason Mazzotta

Re: ssh hangs on HPUX 10.20 when sending commands

I figured out what the problem was.  I was initially have
authentication problems because the permissions on my authorized_keys,
the directory it resides in, and the parent directory of that directory
did not have proper permissions.  In an effort to figure that problem
out, I had enabled DEBUG3 error reporting in sshd.  In order to see
that information in /var/log/messages, I had to allow it in
/etc/syslog.conf.  Once I had figured out the permission problem, I
reintroduced the output restriction in syslog.conf but didn't return
the output level in sshd to INFO.  Once I reset the logging level for
sshd back to INFO, I could ssh normally again.

Site Timeline