SSH and CVS over SSH Tunnel

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!


I'm trying to get a somehow compicated setup to work. Up to now it
worked from time to time but now i can't get it to work at all any more.

This is my situation:

Linux1 --- NAT Firewall dyn.IP --- Linux2 stat.IP --- Windows dyn.IP

I want to access the Linux1 via SSH from my Windows PC. Therefore I dial
in, send a mail to a POP account that gets checked by my Linux1 and if
there's a mail Linux1 establishes two Remote SSH Tunnels to my Linux2

linux1% ssh -R 2401:localhost:2401 linux2 -R 2422:localhost:22 -N linux2

Therefore my Firewall estabishes a connection to my ISP.

Now I log on from my Windows PC to Linux2 using PUTTY. So far no
problem. But then I try to estabish an SSH connection from there over
the tunnel to Linux1:

linux2% ssh -p 2422 -v localhost

Using the verbose mode I get the following:

OpenSSH_3.4p1, SSH protocols 1.5/2.0, OpenSSL 0x0090607f
6155: debug1: Reading configuration data /etc/ssh/ssh_config
6155: debug1: Applying options for *
6155: debug1: Rhosts Authentication disabled, originating port will not
be trusted.
6155: debug1: ssh_connect: needpriv 0
6155: debug1: Connecting to localhost [] port 2422.
6155: debug1: Connection established.
6155: debug1: identity file /root/.ssh/identity type -1
6155: debug1: identity file /root/.ssh/id_rsa type -1
6155: debug1: identity file /root/.ssh/id_dsa type -1

And than nothing any more.

Basically I mainly need a way to access a CVS repository on Linux1 from
my Windows PC. I do not have any rights on the firewall. I first tried
pserver method (using port 2401) and then ext (connection over ssh). I
know that I still need a tunnel from my Windows PC to Linux2 but that
doesn't seem to be the problem...

Thanx for your help


Site Timeline