Secure shell logon fails with errno 4

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

We have two Sun Solaris servers (SPARC) running Solaris 8, servera and
Non commercial version of Secure shell is installed on both (see
output below).
When we ssh from serverb to servera,everything goes smoothly but when
ssh from servera to serverb,we get the message Authentication
but do not get the prompt.Process hangs like that forever and CTRL-C
is the
only way out.Here is the output,slightly modified :
$ ssh -v -v -v 123.456.78.9
debug: SshConfig/sshconfig.c:2838/ssh2_parse_config_ext: Metaconfig
parsing stopped at line 3.
debug: SshConfig/sshconfig.c:3130/ssh_config_read_file_ext: Read 0
params from config file.
debug: Ssh2/ssh2.c:1707/main: User config file not found, using
defaults. (Looked for '/opt/app/oracle/.ssh2/ssh2_config')
debug: Connecting to 123.456.78.9, port 22... (SOCKS not used)
debug: Ssh2Transport/trcommon.c:3676/ssh_tr_create: My version:
SSH-1.99- SSH Secure Shell (non-commercial)
debug: client supports 3 auth methods:
debug: Ssh2Common/sshcommon.c:537/ssh_common_wrap: local ip =
123.456.78.8, local port = 49511
debug: Ssh2Common/sshcommon.c:539/ssh_common_wrap: remote ip =
123.456.78.9, remote port = 22
debug: SshConnection/sshconn.c:1945/ssh_conn_wrap: Wrapping...
debug: SshReadLine/sshreadline.c:2427/ssh_readline_eloop_initialize:
Initializing ReadLine...
debug: Remote version: SSH-2.0- SSH Secure Shell
debug: Major: 3 Minor: 2 Revision: 9
debug: Ssh2Transport/trcommon.c:1367/ssh_tr_negotiate: lang s to c:
`', lang c to s: `'
debug: Ssh2Transport/trcommon.c:1433/ssh_tr_negotiate: c_to_s: cipher
aes128-cbc, mac hmac-sha1, compression none
debug: Ssh2Transport/trcommon.c:1436/ssh_tr_negotiate: s_to_c: cipher
aes128-cbc, mac hmac-sha1, compression none
debug: Remote host key found from database.
debug: Ssh2Common/sshcommon.c:332/ssh_common_special: Received
SSH_CROSS_STARTUP packet from connection protocol.
debug: Ssh2Common/sshcommon.c:382/ssh_common_special: Received
SSH_CROSS_ALGORITHMS packet from connection protocol.
debug: server offers auth methods 'publickey,password'.
debug: Ssh2AuthPubKeyClient/authc-pubkey.c:1800/ssh_client_auth_pubkey:
Starting pubkey auth...
Agent is not running.
Got 0 keys from the agent.
debug: SshConfig/sshconfig.c:2745/ssh2_parse_config_ext: Unable to
open /opt/app/oracle/.ssh2/identification
Trying 0 key candidates.
All keys declined by server, disabling method.
debug: Ssh2AuthClient/sshauthc.c:319/ssh_authc_completion_proc: Method
'publickey' disabled.
debug: server offers auth methods 'publickey,password'.
debug: Ssh2AuthPasswdClient/authc-passwd.c:105/ssh_client_auth_passwd:
Starting password auth...
oracle's password: debug:
SshReadPass/readpass.c:198/ssh_read_passphrase: got errno 4, system
error Interrupted system call


What is even more interesting is that we logon from other machines
onto both
servera and serverb with no problems at all; The only problem appears
trying to ssh from servera to serverb.

Any hint will be greatly appreciated.


Site Timeline