Read from remote host web01.sti.local: Connection reset by peer

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!


(apologies if this turns up twice, I tried posting via the mailing
list and it didn't show up)

I've got a couple of servers, which have started kicking me out of the
ssh connection just after I enter the correct password, basically I
get prompted for the password, then immediately the following message
"Read from remote host Connection reset by peer
Connection to closed."
Obviously, as far as I know, ssh was working fine on these servers, no-
one else has made changes, and these servers are not internet
connected, nor running yum or up2date etc.

I run the command with "ssh -vvv" and got the debug output to the
command line, however the bit where I get disconnected was;
debug1: Entering interactive session.
debug1: channel 0: free: client-session, nchannels 1
debug3: channel 0: status: The following connections are open:
  #0 client-session (t3 r-1 i0/0 o0/0 fd 4/5 cfd -1)

debug3: channel 0: close_fds r 4 w 5 e 6 c -1
Read from remote host Connection reset by peer
Connection to closed.
debug1: Transferred: stdin 0, stdout 0, stderr

I can provide the full client and server debug log if anyone thinks it
might help.

Any ideas on what has gone wrong here?



Site Timeline