Random Hang problem after SSH2_MSG_SERVICE_ACCEPT

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Threaded View
I've been able to ssh from my machine out to other machines every day
for the past umpteen days, but last night, something must've changed.

I can't ssh out from my machine anymore! Here's what happens if I try
to ssh into any server (I've tried two of them, both which let me in
just fine if I use putty from a windows client here at work). I've
replaced my username/server info with generic stuff but other than that
it's a direct paste:

$ ssh -v myserver.com
OpenSSH_4.2p1 Debian-7ubuntu3.1, OpenSSL 0.9.8a 11 Oct 2005
debug1: Reading configuration data /etc/ssh/ssh_config
debug1: Applying options for *
debug1: Connecting to myserver.com [] port 22.
debug1: Connection established.
debug1: identity file /home/myusername/.ssh/identity type -1
debug1: identity file /home/myusername/.ssh/id_rsa type -1
debug1: identity file /home/myusername/.ssh/id_dsa type -1
debug1: Remote protocol version 2.0, remote software version
OpenSSH_3.8.1p1 Debian-8.sarge.6
debug1: match: OpenSSH_3.8.1p1 Debian-8.sarge.6 pat OpenSSH_3.*
debug1: Enabling compatibility mode for protocol 2.0
debug1: Local version string SSH-2.0-OpenSSH_4.2p1 Debian-7ubuntu3.1
debug1: SSH2_MSG_KEXINIT sent
debug1: SSH2_MSG_KEXINIT received
debug1: kex: server->client aes128-cbc hmac-md5 none
debug1: kex: client->server aes128-cbc hmac-md5 none
debug1: SSH2_MSG_KEX_DH_GEX_REQUEST(1024<1024<8192) sent
debug1: expecting SSH2_MSG_KEX_DH_GEX_GROUP
debug1: SSH2_MSG_KEX_DH_GEX_INIT sent
debug1: expecting SSH2_MSG_KEX_DH_GEX_REPLY
debug1: Host 'myserver.com' is known and matches the RSA host key.
debug1: Found key in /home/myusername/.ssh/known_hosts:6
debug1: ssh_rsa_verify: signature correct
debug1: SSH2_MSG_NEWKEYS sent
debug1: expecting SSH2_MSG_NEWKEYS
debug1: SSH2_MSG_NEWKEYS received
debug1: SSH2_MSG_SERVICE_ACCEPT received

.....and thats it! No login prompt, nothing! It just hangs here
forever! The same thing happens if I try to use the -l switch and enter
as a user...it sits here and hangs until I Ctrl+C it.

I am behind a router, but I've been able to successfully connect to the
server using another (windows) machine on my network.

I am running Ubuntu Dapper (6.06LTS),

Re: Random Hang problem after SSH2_MSG_SERVICE_ACCEPT

I should also mention that the same problem occurs if I type in an IP
directly, so I doubt it's a DNS issue....

Re: Random Hang problem after SSH2_MSG_SERVICE_ACCEPT

Quoted text here. Click to load it

That's no guarantee as the problem might be the server doing a reverse
lookup on the address of the client.

Darren Tucker (dtucker at zip.com.au)
GPG key 8FF4FA69 / D9A3 86E9 7EEE AF4B B2D4  37C9 C982 80C7 8FF4 FA69
    Good judgement comes with experience. Unfortunately, the experience
usually comes from bad judgement.

Re: Random Hang problem after SSH2_MSG_SERVICE_ACCEPT

Having been hit with the same issue, I googled around a little and
found this bug report:
which appears to show the same bug in action. I am also able to ssh
out from tty1, but not from within kde (Ubuntu Edgy Eft).


Quoted text here. Click to load it

Site Timeline