Q: KeepAlive not working

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Threaded View
My laptop (Debian Woody unstable) is behind a Linksys router acting as
a firewall (all ports from inside allowed out, only 22, 80, 443
allowed from outside).  When I ssh to machines inside the LAN, they
never disconnect. If I connect to a machine outside of the LAN (DMZ),
it hangs after about 5 minutes of idle time, despite the fact that I
have "KeepAlive yes" in my sshd_config file.

I imagine that it have something to do with my Linksys box, but I
can't figure out what.

Any ideas?

Thanks, Ralph

Re: Q: KeepAlive not working

Quoted text here. Click to load it

KeepAlive will turn on TCP keepalives, which by default are 2 hours
apart.  You can try ClientAliveInterval (server side).  Debian also
ships with a third-party keep-alive patch for the client side, but I
don't remember the option for that (check the man page for ssh_config).

Quoted text here. Click to load it

There have been at least 3 other reports of LinkSys-related SSH problems.
See http://bugzilla.mindrot.org/show_bug.cgi?id=510

Darren Tucker (dtucker at zip.com.au)
GPG key 8FF4FA69 / D9A3 86E9 7EEE AF4B B2D4  37C9 C982 80C7 8FF4 FA69
    Good judgement comes with experience. Unfortunately, the experience
usually comes from bad judgement.

Site Timeline