putty question

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Threaded View
How do I keep the title bar from changing when I first login?

Environment: putty on WinXP pro to connect to a Linux box.

Here's the situation: I need to have many session windows open. I want to
name each with the name of the file I'm editing (or whatever else that
window is dedicated to).

So, I give the session the name of the file I'm editing, e.g., junk.c, in
the Appearance - Window title field and save the session.

OK. So I now connect with that session and I see junk.c in the title bar
and I'm presented with the 'login:' prompt. But, once I actually login to
the linux box the title bar changes from junk.c to royg@machine:/home/royg.

How do I prevent this from happening? How do I keep the title bar at junk.c
(or automatically have it reset to junk.c.

One other thing. After I first login and get the title I don't want, I
still have to login to my personal linux box. However, the title doesn't
change on doing this. So, why does it change on the first login? Is there
some setting on the linux box I'm connected to?



Re: putty question

One of your personal or shell startup files are sending terminal escape
sequences to reset the title.  Find that and turn it off.

  Richard Silverman

Re: putty question

Yes, that was it.

Thank you!


Quoted text here. Click to load it

Site Timeline