putty not negotiating ssh version

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Threaded View
Hello I'm using putty to connect to both ssh1 and ssh2 servers.  Im
using putty .54.  In the ssh setting you have the option of setting 1
only, 1, 2, 2 only.  I have it set to 2.  According to the doc putty
should attempt to auto negotiate ssh version but this does not seem to
be happeneing.  Attached is my event log.

2004-07-02 13:13:23    Looking up host "x.x.x.x"
2004-07-02 13:13:23    Connecting to x.x.x.x port 22
2004-07-02 13:13:24    Server version: SSH-1.99-2.0.13 (non-commercial)
2004-07-02 13:13:24    We believe remote version has SSH2 HMAC bug
2004-07-02 13:13:24    We claim version: SSH-2.0-PuTTY-Release-0.54
2004-07-02 13:13:24    Using SSH protocol version 2
2004-07-02 13:13:24    Doing Diffie-Hellman key exchange
2004-07-02 13:13:25    Host key fingerprint is:
2004-07-02 13:13:25    ssh-dss 1024
2004-07-02 13:13:25    Initialised Blowfish client->server encryption
2004-07-02 13:13:25    Initialised Blowfish server->client encryption
2004-07-02 13:13:27    No supported authentications offered.

Am I doing something wrong or can putty auto negotiate ssh versions?


Re: putty not negotiating ssh version

There is no problem with protocols version; it's using SSH-2.  The problem
appears to be that the client and server have no user authentication
methods in common.

  Richard Silverman

Re: putty not negotiating ssh version

Quoted text here. Click to load it
Quoted text here. Click to load it

What are you expecting to see here?

You've asked PuTTY to use the SSH-2 protocol if it can, and fall back to
SSH-1 otherwise. In your event log extract, the server speaks first and
offers both protocols ("SSH-1.99" means this). PuTTY has picked SSH-2
and indicates this by responding with "SSH-2.0". Both sides then
continue with the SSH-2 protocol (you wouldn't see "Diffie-Hellman key
exchange" in SSH-1).

You're then getting the message "no supported authentications offered",
but that's nothing to do with SSH version negotiation; the settings in
PuTTY that affect this are on the "Auth" panel. In PuTTY's default
configuration (which has `keyboard-interactive' authentication enabled),
the only cause of that that I can think of off the top of my head would
be that the server does not support password authentication but instead
requires (say) public-key, and you haven't specified a private key.

Site Timeline