putty dynamic port forwarding

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Threaded View
Hi all,

I've struck a strange problem with putty and setting up dynamic port
forwarding in conjunction with the firefox web browser.

I have got putty connected from my pc to a remote opensshd server
running on Ubuntu.  I have port 1080 configured as a dynamic port
forward in putty.  The connection is working.

Now, correct me if I'm wrong, but shouldn't I now be able to set the
proxy in firefox on my pc to use port 1080 on localhost, and be able
to use firefox as if it was connecting from the remote server? That
is, should I be able to browse the web etc now that I have firefox
using my port 1080 putty dynamic port forward as a proxy?  I would
have thought so, but I can't seem to get it to work.  Firefox simply
displays a blank page.

I then tried to use the tool "freecap" to hijack firefox and send data
down the dynamic port forward within putty, making sure to set the
proxy setting in firefox to "no proxy". This works fine.  so freecap
is correctly socksifying my firefox connection via my remote ubuntu

So why can't firefox do this with it's own proxy settings?  I am not
sure if this is a problem with putty, or if it's a problem with
firefox, or if my implementation/understanding of dynamic ports is

Would someone be so kind as to help steer me in the right direction
here?  tips/ideas welcome.

BTW I am using putty 0.60, and I also tried a recent nightly build to
see if that made it any better - it didn't.  I am using firefox
3.6.13, which is also the latest stable build.

Thanks all

- Andrew

Re: putty dynamic port forwarding

Quoted text here. Click to load it

I think I found the answer - I think it is a problem with firefox, or
at least the way firefox handles socks proxies by default.

A colleague suggested I try the firefox plugin "foxyproxy", which
enables you to manage proxies a little better.  I setup an entry in
foxyproxy for socks connections to localhost:1080 (make sure you
select that it is a socks proxy not a http proxy) and it works!!

I think the problem might be that firefox doesn't use socks or
something, it's trying a http connect or something like that.  Any

Anyway, using foxyproxy plugin, and ensuring that I specify that it's
a socks proxy, and that I'm using socks 5, and now it works.  I have
no idea why the normal firefox proxy configuration doesn't seem to
work.  ideas?

Thanks anyway, it's funny how you can be trying this for a long while,
finally give up and post a question, then straight away after doing so
you come across a winning answer all by yourself.

Anyway, I'm still curious why firefox proxy config doesn't work with
putty's dynamic port forwarding proxy setup?  Any comments?

- Andy

Re: putty dynamic port forwarding

Quoted text here. Click to load it
Quoted text here. Click to load it

I've often used Firefox straightforwardly and successfully (most
recently Firefox 3.6) with PuTTY's dynamic SOCKS forwarding, without
installing Foxyproxy or anything like that.

I think you have to uncheck "Use this proxy server for all protocols"
and only fill in the "SOCKS Host" boxes in Firefox.

Site Timeline