Putty and shortcuts pointing to specific sessions on XP

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Threaded View
This maybe more of a Windows question (or not?), but I'll shoot it
anyways, in the hope that this is the correct place...

I'm working with Putty 0.57 on Windows XP. I'm not able to set a
shortcut pointing to a specific session, although I did see the FAQs
and the use of the "-load mysession" switch.

I get an error message saying "The name 'C:\Documents and
Settings\...\putty.exe -load server0' specified in the Target box is
not valid. Make sure the path and file name are correct."

I assure you the path, file name, session name, etc. are all more than
double checked, and still I can't get it to work.

I have also tried the old way of doing it (@session, with one or two
spaces before it). Same result.

I tried launching that session from command line, and I only got the
-load switch to work when I issued the command from the directory
where putty.exe sits. Launching it from another directory, Using a
full path, however I quoted it, did not work for me.

Has anybody encountered this ? I'm hoping I'm not the only one...   :)



Re: Putty and shortcuts pointing to specific sessions on XP

Quoted text here. Click to load it

For 'Target:' I have..
"C:\Program Files\PuTTY\PUTTY.EXE" -load <session>
For 'Start in:' I have..
"C:\Program Files\Putty"

Quoted text here. Click to load it

From C:\, I had no problem with...

C:\>"C:\Program Files\PuTTY\PUTTY.EXE" -load <session>

I did this with 0.56 and 0.57.  Windows XP Pro.

Darren Dunham                                           ddunham@taos.com
Senior Technical Consultant         TAOS            http://www.taos.com /
Got some Dr Pepper?                           San Francisco, CA bay area
         < This line left intentionally blank to confuse you. >

Re: Putty and shortcuts pointing to specific sessions on XP

* James Schnack wrote:
Quoted text here. Click to load it

"C:\Program Files\PuTTY\putty.exe" -load server0

Note the arguments go outside the quotes.  You say the paths, filenames
etc are all double-checked, but if those quotes are in the wrong place,
you will get that error.  I just tested both scenarios, and I think that
is your problem - I emulated your error message with the double quotes
outside the args.

I actually didn't know about that option, so I have just learned
something new about putty (which I use all the time from work) so

T R O Y  P I G G I N S
e : usenet@piggo.com

Re: Putty and shortcuts pointing to specific sessions on XP

Thanks Darren & Troy.

Actually I *was* leaving the -load switch out of the quotes, so your
input solved it for me. Come to think of it, it does make sense, but I
had not tried that one... (blush)

I appreciate your help!

Site Timeline