Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Threaded View
I setup a connection to a server behind a firewall using the tunnel
function in putty (v. 0.56).
Even though the number of seconds between keepalive has been set to 60,
after some minutes of idle the connection is dropped.
Does anyone know if there's a way to forward keepalive packets to the
target host with putty?


Re: Putty

Hi Alex

Quoted text here. Click to load it

Have you enabled the option "Enable TCP keepalives" in PuTTY? It is
right under field you enter seconds between keepalives. Maybe this will
keep your connection running.

Another possibility is to check the configuration of the SSH daemon. The
ssh daemon supports two sorts of keep alive messages: TCP keepalive
messages and SSH specific alive messages. For details about this options
please check the following paragraphs in sshd_config(5):


The enabling of one or both of these keep alive messages may help solve
your problem.


Re: Putty

Bruno Flueckiger wrote:
Quoted text here. Click to load it

Also might want to consider upgrading to 0.58. 0.56 had some security
issue. There have also been numerous bug fixes between the releases.

Site Timeline