Problems with libcrypto

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Threaded View
Alright folks, built SSH a ton of times before and always worked
through it, but not having any luck this time.
Building OpenSSH 4.3p2 on an IBM AIX 5.3 TL6 system with zlib 1.2.3
installed and OpenSSL 0.9.8b installed in the default /usr/local/ssl
dir tree. Issuing this command:
./configure --with-zlib=/usr/local/include --with-ssl-dir=/usr/local/
ssl and getting the dreaded:
Can't find recent OpenSSL libcrypto

libcrypto.a IS present in /usr/local/ssl/lib and that dir IS in the

The config.log file has 700 more lines BELOW the Openssl error (which
says nothing more than the same error)
all of which have nothing to do with SSL.

Any thoughts?  Many thanks in advance. -james

Re: Problems with libcrypto

 if anyone cares or this helps, I have solved the problem.

  When using a 64 bit compiled OpenSSL distribution AND trying to
compile OpenSSH with IBM's vac 8.0 compiler, the compiler can't seem
to find the .RAND_add function in the symbol table for the libcrypto.a
archive.   Even though I compiled zlib and ssl with vac8.0, the
solution was to either A) compile ssh with gcc or use ver 6 or earlier
of the vac compiler.  Both vac 6 and gcc were able to read the symbol
table of the libcrypto archive properly.

On Mar 11, 1:01=A0pm, wrote:
Quoted text here. Click to load it

Site Timeline