Problems to use ssh over stunnel and proxyserver

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!


I have a few problems concerning a ssh-connetion through a proxyserver.
The proxyserver is configuered to accept only ports 80 and 443. Trying
to run sshd on port 443 of the server fails because the proxy does not
accept the protocol. Therefore, i run stunnel on the server. The
interesting part on the serverside stunnel.conf is

accept  = 443
connect = 22

while on the client side, i have

; Use it for client mode
client = yes

accept  = 8443
connect = my.home.server:443

Now, i can do

ssh -p 8443 localhost

on the client and get connected to the server at home. The server logs
this as

Jan 11 18:15:31 suse10-1 sshd[9836]: Accepted publickey for wolfgang
from port 16626 ssh2

Obviously, in the view of sshd i connect from localhost. This is a
consequence of using stunnel. Is there any security risk because of this?

The second point: This connection does not use the proxyserver. It only
works, if i can use port 443 on the client. This will not be possible in
future and i only can connect over a proxyserver. Therefore, i added the
following lines to my

Host AtHome
        User wolfgang
        ServerAliveInterval 30
        ProxyCommand ~/bin/proxytunnel -e -p \
    -d my.home.server:443 \
    -H "User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Win32)"

and tried

ssh AtHome

This fails, and in the logfile i find the line

Jan 11 18:06:09 suse10-1 sshd[9716]: Bad protocol version identification
'GET / HTTP/1.1' from

The program proxytunnel is

localhost:~ wolfgang$ ~/bin/proxytunnel -version
SSL enabled
Proxytunnel 1.6.3
Copyright 2001-2006 Proxytunnel Project

Does anybody know, what is going wrong there?

Thank you for any help

Site Timeline