Problem with SSH

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Threaded View
Hi guys,

i have the following problem:
there is a box with OpenSSH_2.3.0p1 and one with OpenSSH_4.2p1.
I want to scp from the old one with scp and a rsa-key to the new one.

but this isn't possible because the old version uses a different pubkey
file format. any ideas how i can convert the old to the new
version? Will this solution even work? :)

Mit freundlichen Grüßen

Franz Bettag

QS Housing
Franz Bettag
Ludwigstr. 45-47
90402 Nürnberg

Tel: +49 1805 737376 664
Fax: +49 1805 737376 665

Re: Problem with SSH

Quoted text here. Click to load it

I'm not aware of any differences in file format (although really old
old version used authorized_keys2 for SSHv2 keys).  I do recall that
versions of that vintage had a bug in DSA (or was that RSA?) key handling,
so it may be worth trying both if you haven't already.

Darren Tucker (dtucker at
GPG key 8FF4FA69 / D9A3 86E9 7EEE AF4B B2D4  37C9 C982 80C7 8FF4 FA69
    Good judgement comes with experience. Unfortunately, the experience
usually comes from bad judgement.

Site Timeline