PRNG not seeded

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Threaded View
I have installed OpenSSH 3.7.1p1-pwexp24 (that's with Darren Tucker's
password expiration patch) on a couple dozen AIX servers - a mix of
4.3.3, 5.1, and 5.2.  I just upgraded a server from 5.1 to 5.2 and
reinstalled SSH.  I can logon successfully, but when I try to SSH to
another server from there, I receive the following error:
PRNG is not seeded

What am I missing?

FYI, I have compiled a separate version for AIX 5.2 because on 5.1 and
earlier, I had to install EGD for random-number generation.  With 5.2
I can configure SSH to use /dev/random.  This has worked fine on all
my other AIX 5.2 servers until now.  And BTW, this is the first one
I've migrated from 5.1 rather than install from scratch, if that makes
a difference.

Thanks for any help,

Steve Bassler
Systems Programmer
Allegheny Energy
Greensburg, PA, USA

Re: PRNG not seeded (Steve Bassler) wrote in message
Quoted text here. Click to load it

Use /dev/urandom.

Re: PRNG not seeded

Quoted text here. Click to load it

It turns out that after the migration install, both /dev/random and
/dev/urandom came in with permissions crw-r-----, where on all my other
AIX 5.2 servers (installed from scratch), they are crw-r--r--.  Once I
added the world readable bit to both, everything worked fine.

One more entry in the "Things that make you go 'Huh?'" file.


Site Timeline