Private key not found or used when starting psftp (putty sftp) client connection

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Threaded View
I'm trying to connect to a SSH version 2 sftp server with a putty sftp
version .54 Windows 2000 based client. I created the right format
public and private key pair and enalbed the public key and
authentication file as per instructions on the sftp server. I also
encryted my private key with a passphrase. Both public key and
password authentication is enforced on the server.

When I connect to the server via "psftp.exe user_name@server_name" I
am prompted to enter the password for the user name instead of the
passphrase for my private key, that I was expecting. It appears that
the primary authentication (public key) is ignored because the client
can't find the private key.

I added the private key to the same directory from which I launched
psftp.exe. Is there a specific directory/directory path where the
private key needs to reside or does anyone know of a command line
option for psftp.exe to specify the path of the private key that is to
be used for authentication ?

I'm 99.9% centain that that there is no problem on the sftp server as
other sftp client software work just fine.

Re: Private key not found or used when starting psftp (putty sftp) client connection

Quoted text here. Click to load it

0.54 has a serious vulnerability. You should use the current version,

Quoted text here. Click to load it

You can tell better whether PSFTP is attempting to use a public key by
adding the "-v" (verbose) option.

Quoted text here. Click to load it

You need to tell PSFTP to use the key -- it won't magically detect its

You can do this either by providing "-i filename.ppk" on the command
line, or by directing PSFTP to use a PuTTY saved session that has been
configured to use that key.

Re: Private key not found or used when starting psftp (putty sftp) client connection

From Putty help :

Like PuTTY, PSFTP can authenticate using a public key instead of a
password. There are two ways you can do this.

Firstly, PSFTP can use PuTTY saved sessions in place of hostnames. So
you might do this:

?    Run PuTTY, and create a PuTTY saved session  which specifies your
private key file  You will probably also want to specify a username to
log in as

?    In PSFTP, you can now use the name of the session instead of a
hostname: type psftp sessionname, where sessionname is replaced by the
name of your saved session.

Secondly, PSFTP will attempt to authenticate using Pageant if Pageant
is running  So you would do this:

?    Ensure Pageant is running, and has your private key stored in it.

?    Specify a user and host name to PSFTP as normal. PSFTP will
automatically detect Pageant and try to use the keys within it.

So check your pageant have loaded your keys or follow the first step,
just create an ssh session with key authentication and try psftp with
name of the session. Try it ..All the best

Site Timeline