Port Forwarding Still Corrupted??

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Threaded View
Hi there!

I'm using the latest Putty software (for Windows) to connect to my
Linux systems out in the field.
At the same time I'm using the port-forwarding feature to allow me to
access webpages available to the system to which the SSH session is
connected to.

However often my webpages didn't fully load.
So after lots of traces me and my colleague discovered that the cause
had to be the Putty Client and not our own servers, since any other
SSH clients worked without any issue.

It appears that the putty SSH tunnel fro some reason sometime does not
tunnel the full data, but only a small part of it. Looking deeper into
the problem we found this page describing exactly what was wrong;


My question is whether anyone is aware that this problem is still
Also if someone might know a workaround.

Re: Port Forwarding Still Corrupted??

Quoted text here. Click to load it

Very recently, I experienced a similar loss of data (in my case,
sporadic web page truncation) when using port forwarding from PuTTY
v0.60 under Windows XP to a remote Linux host.

Quoted text here. Click to load it

The workaround for me was to run PuTTY under Linux, problem solved!

Re: Port Forwarding Still Corrupted??

Quoted text here. Click to load it

Thank You Jim,

The description of your error very much matches mine and I think that
it would caused by be the same problem.
So perhaps we can conclude that this issue only occurs under Windows.
Too Bad my boss won't allow me to work under Linux, (allthough I do
have it running!)

Anyway the problem seems to be related to Windows Clients only.
That might surely help the guys at development, I would think.

Site Timeline