PermitRootLogin not overriding rlogin=false setting

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

OS = AIX5200-06

with 'PermitRootLogin=yes' in sshd_config I get the following

if rlogin=false for root, no ssh connection possible:-
Received disconnect from x.x.x.x: 2: Remote login for account root is
not allowed.

Changing rlogin=true for root allows login.

I was under the impression that the 'PermitRootLogin' setting overrides
the rlogin=false setting (Docs I have read certainly indicate this).

Apparently a collegue has managed to get this working using the same
settings (Only difference is that he is using openssh3.7.1).

Has anyone else seen this behaviour and does anyone have a config
change to allow root logins with ssh without enabling rlogin?

Site Timeline