openssh on win2k server - a couple of hints

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Just passing this information along. Hope it helps.

I was running sshd in debug mode from CMD.exe and was getting the
following message on the client:

Enter passphrase for key 'id_dsa':
debug1: permanently_set_uid: 11120/10413
setreuid 11620: Permission denied
debug1: do_cleanup

It appears that this is not an error. The software worked once I
started the "OpenSSH Server" service.

I'm just passing this information along so others don't waste time
with an apparent error.

Also note the remote user probably needs to login to the HOST server
to create the "x:\documents and settings\username" folder. Then
create/copy the .ssh folder beneath that directory and add the
authorized_keys files in there. OpenSSH's password file doesn't like
UNC paths in the password file. After the login the /home/username
will work in the passwd file. Don't forget to "chmod -R 700 .ssh" and
"chown -R username .ssh" in the "\Documents and Settings\username"

God bless,

-snip from readme.txt file include with software distribution
OpenSSH for Windows v3.8.1p1-1: Readme
Michael Johnson

Updated 9 July 2004

Site Timeline