openssh not tunneling X

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Threaded View
        I am having a bloody hard time forwarding Xwindows
applications through ssh from a AIX 5.3 box in my ubuntu box. At first
I thought it did not have X11Forwarding setup to "yes" in  the sshd-
config file.  I does.

# X11Forwarding no
X11Forwarding yes
X11DisplayOffset 10

I did restart sshd just in case to make sure that is being used. BTW,
we are using openssh:

[aixblade:/etc/ssh] ssh -V
OpenSSH_4.3p2, OpenSSL 0.9.7g 11 Apr 2005

Here is some output from connecting to the said machine using ssh -
vvvX raub@aixblade:

debug2: x11_get_proto: /usr/bin/X11/xauth  list :0.0 2>/dev/null
debug1: Requesting X11 forwarding with authentication spoofing.
debug2: channel 0: request x11-req confirm 0
debug2: client_session2_setup: id 0
debug3: Ignored env DISPLAY
debug3: Ignored env LESSCLOSE
debug3: Ignored env COLORTERM
debug3: Ignored env XAUTHORITY
debug3: Ignored env _
debug2: channel 0: request shell confirm 0
debug2: fd 3 setting TCP_NODELAY
debug2: callback done
debug2: channel 0: open confirm rwindow 0 rmax 32768
debug1: Remote: No xauth program; cannot forward with spoofing.
debug2: channel 0: rcvd adjust 131072
Last unsuccessful login: Mon Jul 23 11:49:20 CDT 2007 on ssh from
Last login: Mon Jul 23 12:59:52 CDT 2007 on /dev/pts/0 from
*  Welcome to AIX Version
5.3!                                                *
*  Please see the README file in /usr/lpp/bos for information
pertinent to    *
*  this release of the AIX Operating
System.                                  *

The first hint I had, besides the verbose output shown above, that
things were boink was that DISPLAY was not defined by ssh. The, I
tried to connect from a XP laptop which has xming and putty and has no
problem connecting to and forwarding X11 application in other machines
(Solaris, linux) also running openssh.  I did compare the sshd_config
files and could not find any clues. What should I check next? And,
what is his problem with xauth? AFAIK, it is there:

[aixblade:/etc/ssh] which xauth

Re: openssh not tunneling X

             Specifies the full pathname of the xauth(1) program.  The default
             is /usr/X11R6/bin/xauth.

  Richard Silverman

Site Timeline