openssh compile problems after upgrading to openssl 0.9.7b

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

I just upgraded to openssl 0.9.7b (Gentoo-Linux running 2.4.20) and get
a comile error when trying to recompile openssh against the new
libraries. Here are the last few lines of the error message. I can send
the whole compilation output if required. thanks in advance for any help.

ranlib libssh.a
gcc -o ssh ssh.o readconf.o clientloop.o sshtty.o sshconnect.o
sshconnect1.o sshconnect2.o -L. -Lopenbsd-compat/  -lssh
-lopenbsd-compat -lutil -lz -lnsl -lcrypto
./libssh.a(rsa.o)(.text+0x269): In function
: undefined reference to `BN_mod'
./libssh.a(rsa.o)(.text+0x29b): In function
: undefined reference to `BN_mod'
collect2: ld returned 1 exit status
make: *** [ssh] Error 1
make: *** Waiting for unfinished jobs....

!!! ERROR: net-misc/openssh-3.6.1_p2 failed.
!!! Function src_compile, Line 92, Exitcode 2
!!! compile problem

Site Timeline