Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Threaded View

I find this version on my Tandem/OSS platform really slow (a ten-line
ls output from sftp takes five minutes!).  I read some postings about a
nodelay sshd_config setting in the version that seem to be the

Is there an equivalent setting in OpenSSH.  Has the speed issue
of 3.7.1p2 been resolved?

Many thanks.

Re: OpenSSH_3.7.1p2

Quoted text here. Click to load it

I have had reports of very slow behaviour (on Solaris) which we eventually
tracked as far as the handling of TCP_NODELAY.  Hacking ssh to not use
it (ie leave the Nagle aglorithm enabled) restored the speed to normal.
The patch below does this but it's a workaround not a real fix.

Quoted text here. Click to load it

If it's the above then the issue isn't with OpenSSH, it's with one of
your TCP stacks.

Index: misc.c
RCS file: /usr/local/src/security/openssh/cvs/openssh_cvs/misc.c,v
retrieving revision 1.48
diff -u -p -r1.48 misc.c
--- misc.c    5 Jul 2005 23:44:19 -0000    1.48
+++ misc.c    7 Jul 2005 03:19:50 -0000
@@ -102,6 +102,8 @@ set_nodelay(int fd)
     int opt;
     socklen_t optlen;
+    return;
     optlen = sizeof opt;
     if (getsockopt(fd, IPPROTO_TCP, TCP_NODELAY, &opt, &optlen) == -1) {
         debug("getsockopt TCP_NODELAY: %.100s", strerror(errno));

Darren Tucker (dtucker at
GPG key 8FF4FA69 / D9A3 86E9 7EEE AF4B B2D4  37C9 C982 80C7 8FF4 FA69
    Good judgement comes with experience. Unfortunately, the experience
usually comes from bad judgement.

Site Timeline