OpenSSH 3.7.1 RSA auth

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Threaded View

Being unable to install OpenSSH 3.7.1 on OpenBSD 2.9, I upgraded to OpenBSD
3.3 and installed OpenSSH 3.7.1. Since the upgrade I'm having trouble with
the keys. :-(

I created a new key on the machine and tried to ssh to itself using key
based authentication but it fails. Here is the debug output.

/home/user $ ssh -v -2 -i ./.ssh/id_rsa
OpenSSH_3.7.1, SSH protocols 1.5/2.0, OpenSSL 0.9.7-beta3 30 Jul 2002
debug1: Reading configuration data /etc/ssh/ssh_config
debug1: Connecting to [] port 22.
debug1: Connection established.
debug1: identity file ./.ssh/id_rsa type 1
debug1: Remote protocol version 1.99, remote software version OpenSSH_3.7.1
debug1: match: OpenSSH_3.7.1 pat OpenSSH*
debug1: Enabling compatibility mode for protocol 2.0
debug1: Local version string SSH-2.0-OpenSSH_3.7.1
debug1: SSH2_MSG_KEXINIT sent
debug1: SSH2_MSG_KEXINIT received
debug1: kex: server->client aes128-cbc hmac-md5 none
debug1: kex: client->server aes128-cbc hmac-md5 none
debug1: expecting SSH2_MSG_KEX_DH_GEX_GROUP
debug1: SSH2_MSG_KEX_DH_GEX_INIT sent
debug1: expecting SSH2_MSG_KEX_DH_GEX_REPLY
The authenticity of host ' (' can't be
RSA key fingerprint is 01:99:36:d3:1b:7f:75:02:54:21:9c:19:1d:f2:cb:4d.
Are you sure you want to continue connecting (yes/no)? yes
Warning: Permanently added ',' (RSA) to the list
of known hosts.
debug1: ssh_rsa_verify: signature correct
debug1: SSH2_MSG_NEWKEYS sent
debug1: expecting SSH2_MSG_NEWKEYS
debug1: SSH2_MSG_NEWKEYS received
debug1: SSH2_MSG_SERVICE_ACCEPT received
Connection closed by
debug1: Calling cleanup 0x24e08(0x0)

I have replaced the hostname and IP address.

I tried logging in from a different host and client (putty) bit can't use
the keys. Password authentication works okay.


Re: OpenSSH 3.7.1 RSA auth

Uncomment two lines for SSH2 host keys in the sshd_config file and it will


Chetan Bhargava

Quoted text here. Click to load it

Site Timeline