opehssh shows two new processes upon connection

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Threaded View
using: openssh-3.6.1p2 on Solaris 5.8.

Built and installed openssh-3.6.1p2. This was a vanilla build: NO pam
and NO tcp-wrapper.

When the client connects and additional 2 (!!) sshd processes are seen
on the server, one owned by root and one owned by the user.

When I use the sshd that "came" with the system, it only shows one
additional sshd process when a user connects, which is what I would

This is imporant to us because we want to use pam login_limits. I
discovered that when I did build with login_limits that each failed
attempt from the client bumped the count by 2, not 1. Which can be
seen to make sense if sshd creates two new processes. So, I then
rebuilt opensshd without pam, but got the same result.



Here's a screenshot showing the two new processes showing up.

cello# pwd
wallace# ./sshd
wallace# ps -ef | grep sshd
    root 21843     1  0 12:25:19 ?        0:00 ./sshd

[ Now I connect from a client machine ]

cello# !ps
ps -ef | grep sshd
    root 21843     1  0 12:25:19 ?        0:00 ./sshd
 rgordon 21849 21847  0 12:27:05 ?        0:00 ./sshd
    root 21847 21843  0 12:27:05 ?        0:00 ./sshd

Re: opehssh shows two new processes upon connection

royg@semantic.com (roy gordon) writes:

Quoted text here. Click to load it

There isn't any sshd that comes with Solaris 8.

The second process is related to privilege separation.  Add

UsePrivilegeSeparation no

to your sshd_config, restart the daemon, and the "problem" should
be solved.

Site Timeline