KeepAlive (Putty or openssh)

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Threaded View

The VPN for work recently changed so that idle sessions get dropped after
30 minutes.  Not the vpn connection itself just the ssh sessions within it.

I've played with the keep alive option in PuTTy 0.54 and on the Windows
version it seems to work and my sessions stay active but when trying the linux
version of PuTTy setting that option doesn't seem to work.

I've also tried the following from my linux box with openssh

ssh -2 -o 'TCPKeepAlive=yes'

It doesn't give me any errors and in the man page it looks like a valid option,
but it's not working either.

$ ssh -V
OpenSSH_3.8.1p1, OpenSSL 0.9.7d 17 Mar 2004

Does anyone have any ideas on how I can keep my sessions active without having
to work from my Windows system and run PuTTy there?  OpenSSH would rock but
even just figuring out why they linux PuTTy doesn't behave like the Windows
version would be fine.


Re: KeepAlive (Putty or openssh)

Quoted text here. Click to load it
Quoted text here. Click to load it

Try ServerAliveInterval instead.

Darren Tucker (dtucker at
GPG key 8FF4FA69 / D9A3 86E9 7EEE AF4B B2D4  37C9 C982 80C7 8FF4 FA69
    Good judgement comes with experience. Unfortunately, the experience
usually comes from bad judgement.

Re: KeepAlive (Putty or openssh)

Quoted text here. Click to load it

Ahem. Yes, someone pointed this out recently; I mean to fix it at
some stage...
Simon Tatham         "A cynic is a person who smells flowers and

Site Timeline