how to turn on scp compatibility mode ?

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Threaded View

I'm working in a PC running RH9 with openssh-3.5p1-6 installed. When I
try to connect to a Compaq Tru64 UNIX with sshd2 installed through
'ssh' it is ok.

But if I try scp, I get the following:

warning: Executing scp1 compatibility.
Executing ssh1 in compatibility mode failed.
lost connection

I searched the net and discovered that this problem is quite common,
but probably because of my lack of experience, I could not understand
how to solve it. I did understand that I have to, somehow, turn on the
scp1 compatibility in my Linux, but I don't have a clue about how to
do it.

Can anyone tell me how to do that?

Thanks a lot

p.s. by the way, when I try to use sftp, any command shows the message
¨Server version does not support lstat operation¨, but I can transfer
files IF they are not big: if they are big, the transfer never ends.
This is a secondary problem, but if anyone have a suggestion also...

Re: how to turn on scp compatibility mode ?

  Richard Silverman

Re: how to turn on scp compatibility mode ?

That page says ¨The solution is to install either the OpenSSH or SSH1
version of scp on the server under the name "scp1," somewhere in the
sshd2's PATH.¨

But how do I do that? I don't know...

Re: how to turn on scp compatibility mode ?

Quoted text here. Click to load it

Download OpenSSH (or one of the original SSH1 releases, eg ssh-1.2.33).
Unpack the archive, build and copy scp to, eg, /usr/local/bin/scp1.

$ gzip -dc openssh-3.8p1.tar.gz | tar xf -
$ cd openssh-3.8p1
$ ./configure && make
$ su root
# cp scp /usr/local/bin/scp1

Darren Tucker (dtucker at
GPG key 8FF4FA69 / D9A3 86E9 7EEE AF4B B2D4  37C9 C982 80C7 8FF4 FA69
    Good judgement comes with experience. Unfortunately, the experience
usually comes from bad judgement.

Site Timeline