help desperately needed for using PuTTY

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Threaded View

I used PuTTYgen to generate a private key/public key
pair. I saved the private key in my pc and pasted the
public key to the authorized_keys file in my account
at a remote machine. Then I executed the following command

plink -ssh -2 -i d:\orig\archive\keys\ix.ppk

d:\orig\archive\keys\ix.ppk is my saved private key file.  I got the

 Using username "shulc".
 Server refused our key's password:

I still must type in my password to login.  I tried PuTTY itself also, but
the same error message. What is even more confusing is that I got the same
error message
even I completely remove the authorized_keys file from my ~/.ssh directory.
In chapter 10 of PuTTY's manual, there is an explanation of an error
message. I attach it below. I am not sure if it is related to the above
problem I encountered.
I would greatly appreicate it if anyone can provide me any clue. Please send
your reply to

10.7 "Server refused our public key" or "Key refused"
Various forms of this error are printed in the PuTTY window, or written to
the PuTTY

Event Log (see section when trying public-key authentication.

If you see one of these messages, it means that PuTTY has sent a public key
to the server and

offered to authenticate with it, and the server has refused to accept
authentication. This usually

means that the server is not configured to accept this key to authenticate
this user.

This is almost certainly not a problem with PuTTY. If you see this type of
message, the first thing

you should do is check your server configuration carefully. Also, read the
PuTTY Event Log; the

server may have sent diagnostic messages explaining exactly what problem it
had with your setup.

Re: help desperately needed for using PuTTY

Show the debug from the ssh server

LihChyun Shu wrote:

Quoted text here. Click to load it

Site Timeline