Forcing both password and PublicKey Authentication

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Threaded View
Hi ,

Is there a way to force openssh server to accept both key_method and
password for authentication ?

If i enable both, it checks only for one and if it succeeds it does
not go for the second one .

I saw one post and it said no but it is in 2004



Re: Forcing both password and PublicKey Authentication wrote:
Quoted text here. Click to load it

Have you tried setting "UseLogin yes" in sshd_config?  I think after ssh
authenticates it hands off to login for an interactive login session. I
haven't tried "UseLogin yes" myself. It disables X11Forwarding. Also, users
can specify a shell to use. Can you specify a login shell if you trust the
useres not to change it?

Why do you need to authenticate with both a public key and a password?

I hope this helps,
 - Adam W.

Site Timeline