force pts/ppy with ssh tunneling

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Threaded View
i using openssh server for ssh tunneling and then user connect to
server only for tunneling, no pts/tty is open.
user bypass the connection limit, "user hard maxlogins 1" set in /etc/
user don't read the /etc/ssh/sshrc and /.ssh/rc login script.
there is a way, in the server side, to force user open a pts/tty or
force user to execute sshrc/rc script ?????

Re: force pts/ppy with ssh tunneling

i want to specify that the probleme is then client is connected with -
N option like "ssh -v tunnel@ipsshd  -D 55555 -N"

i tryed some tricks to force user to execute script file like :
"ForceCommand =/home/tunnel/" in  /etc/ssh/sshd_config
 /home/tunnel/  in   /etc/ssh/sshrc or   /.ssh/rc
command="/home/tunnel/" ssh-rsa AAAAB3Nza.....  in /home/

but user connected with -N never execute these scripts !!!

maybe there is a way to disable -N option in the sshd deamon ???

Site Timeline