DNS Lookup Problem

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Threaded View
Hi everyone:
     I currently am able to run a secure tunnel from my work computer
to my home computer, using PuTTY and OpenSSH.  The problem I am having
is that some sites are still inaccessible.  The DNS servers at work run
a black list (or black hole list) that causes all IP addresses on the
list to route to nothing.  When I am on my work network, they route to
a page telling me that I have tried to access a restricted page, with a
link provided that lists all restricted domains.  When I am tunneling,
it routes me to the usual, "Page cannot be displayed".  I am almost
certain that this is due to the DNS lookups still being routed through
my work firewall.  If I run 'netstat', I can still see active
connections to what I deem to be the DNS servers at work.  I am trying
to access my personal email accounts on Yahoo!, Hotmail, and Mail.com,
as I sometimes have important messages come there that I would rather
not place in my work account.  I am able to access these accounts when
using HTTP-Tunnel, but the free version of that software is extremely
slow.  Is there some setting in PuTTY that I can change so that DNS
lookups are done securely as well?  If not, I'll just have to deal with
using the slow program.  No biggie.  Any helpful feedback would be
appreciated.  Thanks.

Re: DNS Lookup Problem

lever2k2@hotmail.com writes:
Quoted text here. Click to load it
Quoted text here. Click to load it

Assuming you're using dynamic port forwarding, you need to at least set
the setting described at the following location correctly:

However, that's not much help if the application you're pointing at
PuTTY's proxy insists on doing its own name lookups. IIRC, web browsers
such as Firefox fall into this category.

Re: DNS Lookup Problem

Thanks for your reply.  I am currently configured in PuTTY to
dynamically forward port 1080, using IE 6.  I'll continue playing
around with the proxy settings in PuTTY.  I didn't see any results in
setting DNS to be handled at the proxy or handled locally in PuTTY.  I
have noticed that I see the same behavior (connects everywhere except
blacklisted IPs), no matter if I have my workplace's proxy address
typed in or not.

Site Timeline