Display username and host when prompting for password

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Threaded View

Older versions did display username and hostname when
ssh asks for a password.

Is there a way to get this again?

Version: OpenSSH_3.9p1, OpenSSL 0.9.7d 17 Mar 2004

Background: If you use ssh in ProxyCommand
you don't know which password you need.

Thomas GŁttler, http://www.thomas-guettler.de /

Re: Display username and host when prompting for password

Quoted text here. Click to load it

I assume you're using PAM?  The usual reason for this is that you're
using keyboard-interactive authentication for PAM and the "Password: "
prompt is directly from PAM.  If so, there are two possible options:

a) Configure PAM to provide the host's name in its password prompt

b) Use password authentication instead of keyboard-interactive either
by removing keyboard-interactive from PreferredAuthentications on the
client or by disabling ChallengeResponseAuthentication on the server.

(on OpenSSH 3.7x and 3.8x this would have authenticated without using PAM,
however on 3.9 and up, and 3.6x and below it will use PAM).

Darren Tucker (dtucker at zip.com.au)
GPG key 8FF4FA69 / D9A3 86E9 7EEE AF4B B2D4  37C9 C982 80C7 8FF4 FA69
    Good judgement comes with experience. Unfortunately, the experience
usually comes from bad judgement.

Site Timeline