Delay typing in ssh session

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Well obviously its not the 'typing' that is the problem, but something
to do with ACKs or the MTU or something.

I have two machines connected via a 100mb LAN. and

I have put the entries in the hosts file plus both machines have
access to DNS. (Without this, there is a known noticible delay when
connecting with SSH).

Machine A is a 2.5ghz running WinXP+Cygwin
Machine B is a 350Mhz running Redhat9

I have disabled the firewalls on both machines to rule that problem
out, but I still experience about a 0.5s delay with every letter I
type. Ping times for the machines are only 0.3ms so it is not the
connection at fault.

I have tried SSH'ing through loopback on the Linux machine and it
works fine, so its not a problem with CPU and encryption taking too

I have tried authenicating with both a password, and using dsa keys. I
have tried with and without -X forwarding - which is also painfully

Transferring data between the machines using samba works fine and at
normal speeds.

I saw something in the freebsd groups about disabling delayed_ack, but
havent seen anything else about it.

Does anyone know what could be causing the lag? I have used SSH before
on a LAN with almost zero lag between keystrokes.

Site Timeline