Cygwin SSH timeout problem

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Threaded View
My ssh on Cygwin (latest version) freezes after about 5 minutes of
inactivity.  Can anyone suggest a way to stop this behavior?



Re: Cygwin SSH timeout problem

Quoted text here. Click to load it

2.12 - My ssh connection freezes or drops out after N minutes of

This is usually the result of a packet filter or NAT device timing out
your TCP connection due to inactivity. You can enable ClientAliveInterval
in the server's sshd_config, or enable ServerAliveInterval in the client's
ssh_config (the latter is available in OpenSSH 3.8 and newer).

Enabling either option and setting the interval for less that the time
it takes to time out your session will ensure that the connection is kept
"fresh" in the device's connection table.

Darren Tucker (dtucker at
GPG key 8FF4FA69 / D9A3 86E9 7EEE AF4B B2D4  37C9 C982 80C7 8FF4 FA69
    Good judgement comes with experience. Unfortunately, the experience
usually comes from bad judgement.

Site Timeline