cygwin and ssh problem

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!


 I just installed cygwin from the cygwin website onto  a PC running Windows
2000. I've been trying to get the openSSH that came with cygwin up and running
with mixed success.

THis is weird. I have an account called Administrator, and I've copied a public
key from a user on a Sun U-60 running 2.9 to the authorized_keys2 directory in
the .ssh directory of /home/Administrator.

Running "sftp Administrator@pc" on the Sun at first fails.

Then I run it again, success. I exit. Try it again, it immediately fails. Try
it again, succes and so on, back and forth, hit and miss, hit and miss.

So, OK, run the sshd daemon in debug mode. Well, when I run the sucker in
debug, I don't have this problem. It always succeeds, and of course when the
client exits, the sshd daemon running debug mode exits as well. So I can't
examine this hit and miss behavior.

I have a fair amount of experience with openSSH, but I've never seen anything
quite like this.

Any clues or does anybody recall a similar experience?

(twilight zone music)

THanks in advance,

Dr. Stuart A. Weinstein
Ewa Beach Institute of Tectonics
"To err is human, but to really foul things up
requires a creationist"

Site Timeline