compressed connection problem on 3.7.1p2

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Threaded View

I have OpenSSH 3.7.1p2 installed on a Tru64 system. It accepts
uncompressed connections just fine, but disconnects connections
attempted using compression. Everything seems to go OK, but I get kicked
out bfore I get to the shell prompt.

The output from a connection is reproduced below

my-sys> ssh -C -v -v -l myname rio14


debug1: ssh-userauth2 successful: method publickey
debug1: channel 0: new [client-session]
debug1: send channel open 0
debug1: Entering interactive session.
debug1: channel_free: channel 0: client-session, nchannels 1
Connection to rio14 closed by remote host.
Connection to rio14 closed.
debug1: Transferred: stdin 0, stdout 0, stderr 73 bytes in 4.1 seconds
debug1: Bytes per second: stdin 0.0, stdout 0.0, stderr 17.8
debug1: Exit status -1
debug1: compress outgoing: raw data 1115, compressed 594, factor 0.53
debug1: compress incoming: raw data 513, compressed 521, factor 1.02

I can tinker with the remote configuration and access the logfiles, I'm
just uncertain where to look for lues first of all.

Any suggestions gratefully received.


(email is 'Andy' and 'Law' with a period between them at

Re: compressed connection problem on 3.7.1p2

Quoted text here. Click to load it

The interesting debug messages will be in the server-side debug.  You can
run the server on another port by doing something like "sshd -ddd -p 2022"
then connecting with "ssh -p 2022 yourserver"

Quoted text here. Click to load it

Try disabling Privilege Separation (put "UsePrivilegeSeparation no" into

Darren Tucker (dtucker at
GPG key 8FF4FA69 / D9A3 86E9 7EEE AF4B B2D4  37C9 C982 80C7 8FF4 FA69
    Good judgement comes with experience. Unfortunately, the experience
usually comes from bad judgement.

Site Timeline