cannot start sshd on cygwin- win xp - Page 2

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Threaded View

Re: cannot start sshd on cygwin- win xp schrieb:
Quoted text here. Click to load it

I'm not really sure, but I think there was something special
'installing' sshd on cygwin. There has to be added a special user etc.
But there's a programm called 'ssh-host-config' which, if I recall
right, does everything needed.


Re: cannot start sshd on cygwin- win xp

Quoted text here. Click to load it

I used that page. But had the problem.  Yet it was fine on another

Maybe the win xp on the problem machine needs a win xp repair. But
anyhow, I wasn`t planning on installing sshd as a service, and even if
I did need sshd to run every time, then like any program, you can do
Could start cygwin automatically, it starts the bash shell, and I
could put a line in the file ".bashrc" to execute sshd.  It`s like
DOS`s autoexec.bat but for bash.

reminds me, I did have a problem with the machine where it shutdown
suddenly. Event viewer showed a service starting beforehand. I
disabled or removed that service and the comp was fine again.

reminds me again of a  comp I saw where an application would not
install. It used installshield, I reinstalled installshield, but it
didn`t help. A win xp repair or win xp reinstall fixed it.

On the machine that worked, I did get an error about /var/empty and
did have to do chown on /var/empty  changing the owner to whoever the
windows/cygwin user is that started sshd.   Similarly, only that user
can log in (though maybe sshd-add or whatever can add users and change

Without doing the sshd-host-config thing. If I had just tried to run
sshd, I would not have even been able to run it.  This problem I
described is that it won`t start as a service. But it will run
normally if just executed.

Site Timeline