Cannot connect to SSH from one location

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Threaded View
I run an SSH server on my linux box at home and have been able to
connect to it from my office with no problems.

However, I spend part of my time in my company's other office and I
cannot connect to it at all from there. I presume that there is a
different firewall in the way.

Below are the debug messages I am getting.

OpenSSH_3.1p1, SSH protocols 1.5/2.0, OpenSSL 0x009060af
debug1: Rhosts Authentication disables, originating port will not be
debug1: restore_uid
debug1: ssh_connect: getuid 400 geteuid 400 anon 1
debug1: connecting to www.*removed-to-foil-spammers* []
port 22.
debug1: temporarily_use_uid: 400/401 (e=400)
debug1: restore_uid
debug1: temporarily_use_uid: 400/401 (e=400)
debug1: restore_uid
debug1: Connection established.
debug1: identity file /cygdrive/c/Documents and
Settings/myuser/.ssh/identity type -1
debug1: identity file /cygdrive/c/Documents and
Settings/myuser/.ssh/id_rsa type -1
debug1: identity file /cygdrive/c/Documents and
Settings/myuser/.ssh/id_dsa type -1
ssh_exchange_identification: Connection closed by remote host
debug1: Calling cleanup 0x419c30(0x0)

Any clues on how I can resolve this? I cannot get any changes made to
the firewall itself so any changes would need to be to my server or
client. I tried running the SSH server on port 80 but still couldn't
connect even though port 80 is allowed through the firewall. It looks
as though it does successfully connect to the server but then
something goes wrong and I can't find out what.

It fails with both the Cygwin SSH client and PuTTY.

Any help you guys can provide will be very much appreciated.

Thanks in advance,


Re: Cannot connect to SSH from one location

Quoted text here. Click to load it

Check the logs on the server.  Your connection is probably being dropped
by tcpwrappers and if so, you need to modify /etc/hosts.allow on the

Darren Tucker (dtucker at
GPG key 8FF4FA69 / D9A3 86E9 7EEE AF4B B2D4  37C9 C982 80C7 8FF4 FA69
    Good judgement comes with experience. Unfortunately, the experience
usually comes from bad judgement.

Re: Cannot connect to SSH from one location (Darren Tucker) wrote in message

Quoted text here. Click to load it
Thanks for your advice.

I don't know anything about tcpwrappers as I have not configured them
in any way. Both hosts.allow and hosts.deny are empty (except for
comment lines).  I presume this means that there are no restrictions
on which hosts I can log in from?

I have set the logging level to DEBUG3 in my sshd_config but I get no
entries in any of the logs I have checked - messages, secure etc...

Where is the output from sshd logged on a RH9 system?

Many thanks.

Re: Cannot connect to SSH from one location (Darren Tucker) wrote in message

I have just tried connecting from the 'good' office and the debug
messages appear in the messages log. Connecting from the 'bad' office
means no messages appear. I take this to mean that the bad connection
is not even getting as far as the ssh daemon. The firewall on my linux
box is not blocking port 22 - or it would not work from either
location - so is there anything else on my Linux machine (a standard
RH9 installation) which might be dropping the connection?

Failing that, could it be that the firewall I am behind at the 'bad'
office recognises that the tcp packets are for SSH and so drops them?

Thanks again,


Site Timeline